Back to overview
Resolved
We have found a fix
Jul 20, 2026 at 11:12am UTC
Affected services
beta.tailorbird.com/api/health
Resolved
Jul 20, 2026 at 11:14am UTC
We have resolved the issues and all systems are running
Affected services
Created
Jul 20, 2026 at 11:12am UTC
Fix have been found and we are working on the fix. Some services maybe running while some are still experiencing degraded service
Affected services